httpd.exe mod_ssl.so The operating syste m cannot run %1.

I was upgrading my development server (WAMP) from Apache 2.2 (x32) to Apache 2.4 (x64) today. Everything went smoothly and was working without special modifications, except the ssl_module mod_ssl.so. I’ve almost got mad, because server didn’t start. My issue was httpd.conf: Cannot load modules/mod_ssl.so into server: The operating system cannot run %1. Usually error message…

Read More

Foundation and IE8

The Foundation is a free front-end framework. The framework is really easy to use and it supports all modern browsers and browsers on mobile devices. The problem is when you want to use the Foundation on old and outdated Internet Explorer 8 or 7. At ZURB decided to support only modern browsers since Foundation 4…

Read More

Compress/minify JavaScript and CSS files

We can find a lot of JavaScript free compress/minify tools: Javascript Compressor JsMini.com JSCompress.com uses UglifyJS blimptontech uses UglifyJS 2 YUI Compressor I will write something about the YUI Compressor. YUI Compressor is written in Java and relies on Rhino to tokenize the source JavaScript file. You can download the latest version of YUI Compressor…

Read More

Android: Check if Internet connection is available

If the application wants to check if the Internet connection is available, we must add the application permission: ACCESS_NETWORK_STATE. I already wrote how to set the Application permissions. The Android API provided two classes: ConnectivityManager – Class that answers queries about the state of network connectivity NetrowkInfo – Describes the status of a network interface…

Read More

Android: Application permissions

The applications sometimes need special permission – access to your camera, read your contacts,… Without setting the permissions the application cannot access to them. In the Manifest file we can declare them with the uses-permission. A list of permissions defined by the base platform can be found at android.Manifest.permission. The Access Control application will require…

Read More

Android: How to set minimum API level?

Some applications are written for newer Android platform version and they don’t work on older platforms. We can prevent users to install applications on their devices. We had to set android:minSdkVersion to the AndroidManifest.xml. The complete list of API levels is available in the Android Manifest documentation. It’s good to know how many devices are…

Read More

Android: Access control

My boss gave me very interesting project – create an Android application for an integrated access control system (Ticket Monitor). Because of the company policy I am not allowed to write all the details, but I can write something about it. These days almost everyone has a device with a an Android OS. So, we…

Read More